En este episodio aprendemos a actualizar la versión de PHP para WordPress tras comprobar la compatibilidad con los plugins y themes de nuestro sitio.

Muchas veces te he recomendado que elijas un proveedor de hosting de calidad y especializado en WordPress para que no te lleves sorpresas a la hora de confiarle tu sitio web y todo funcione de forma correcta. Hoy aprendemos a actualizar la versión de PHP para WordPress.

En concreto, WordPress necesita que un hosting cumplan con 3 requisitos necesarios para que funcione de forma correcta:

  • PHP versión 7.2 o superior.
  • MySQL versión 5.6 o superior O MariaDB versión 10.0 o superior.
  • Compatible con HTTPS

Aunque, a día de hoy WordPress funciona con una versión de PHP a partir de la 5.2.4, lo cierto es que tu sitio podría estar expuesto a agujeros de seguridad o vulnerabilidades con versiones anteriores a la 7.2.

Además, todo parece indicar que WordPress 5.0 ya será compatible con PHP 7.3

Comprobar la versión PHP a través de WordPress

Mediante un plugin

Puedes utilizar:

Manualmente

En este caso tendrías que ir hasta tu hosting, concretamente hasta la carpeta raiz, y crear un nuevo archivo llamado phpinfo.php.

En este archivo tendrás que escribir estas líneas de código (muy sencillo, no te asustes)

<?php 
phpinfo();
?>

Una vez subido al hosting, teclea en tu navegador “https://tudominio.com/phpinfo.php” y te aparecerá la información en la pantalla.

Ojo, no olvides borrar después ese archivo!!

Comprueba la compatibilidad

Antes de modificar la versión de PHP que tienes en tu servidor, es preferible que compruebes la compatibilidad de todos los plugins y themes que tienes instalados.

Con esto evitarás que después de actualizar la versión PHP te encuentres con algo que no sea compatible y rompa tu sitio.

En este caso, te recomiendo que instales el plugin PHP Compatibility Checker. Después de instalarlo y activarlo, simplemente debes hacer un scanner: elegir qué plugins o themes quieres comprobar y con qué versión de PHP (de las 3 últimas) quieres comprobar la compatibilidad.

Te saldrán en verde los componentes que son 100% compatibles, en gris los que tienen un estado “desconocido” y en rojo los que presentarían alguna incompatibilidad con esa versión de PHP

Modificar la versión de PHP en tu hosting

Una vez comprobado que no se va a romper nada en tu sitio web al actualizar la versión de PHP, toca ponerse manos a la obra y hacerlo.

Para ello tendrás que acudir hasta el Panel de Control de tu hosting (por lo general CPanel) y ahí buscar el apartado “Software”. Tendrás una opción que pone “MultiPHP” o “Seleccionar versión de PHP”.

Simplemente tendrás que pinchar sobre uno de estos iconos y seleccionar la versión de PHP a la que desees actualizar (siempre y cuando esté disponible en tu proveedor de hosting)

Actualizar la versión PHP de WordPress

Hay algunos proveedores de hosting, como SiteGround, que disponen de un plugin que te permite actualizar la versión de PHP desde tu WordPress con un simple clic.

También Webempresa tiene otro sistema un poco distinto, y puedes actualizar la versión a través del asistente virtual Stephan, desde su Panel de Control interno.

Si no localizas este icono o esta opción en tu Panel, te recomiendo que abras un ticket de soporte en tu hosting, para que se encarguen ellos de hacerlo. Seguro que en cuestión de minutos lo tendrás solucionado.

Sorteo Octubre 2018

Te recuerdo que, durante todo este mes de Octubre, tenemos en marcha un nuevo sorteo, entre todos los lectores de este blog y oyentes del podcast, gracias a nuestro patrocinador LucusHost.

En esta ocasión está en juego un pack compuesto por:

  • 1 consola Nintendo NES Mini
  • 1 año de hosting Junior SSD + dominio

Para participar, sólo tienes que tener una cuenta de Twitter y seguir las instrucciones que hay en el post donde te hablaba sobre el sorteo de Octubre 2018 de WPnovatos.

Plugin recomendado

Child Themify

 

Noticias WordPress

Esta semana, Gutenberg sigue dando que hablar. El líder del equipo de accesibilidad de Gutenberg, Rian Rietveldha presentado su renuncia dados los grandes problemas con los que se ha venido encontrando en el proceso.

“No hubo un desarrollador de REACT con experiencia en accesibilidad en la comunidad, y no hay expertos en accesibilidad de REACT de fuera de la comunidad que estén dispuestos a trabajar en los temas de forma gratuita.”

Según comenta Rian en el comunicado publicado en su blog, en versiones anteriores fue mejorada bastante la accesibilidad, pero al lanzar nuevas versiones posteriormente, se volvió a romper todo.

La encargada del proyecto en GitHub, Andrea Fercia, por su parte, manifiesta:

“Si bien el equipo de Gutenberg ha trabajado arduamente para implementar algunas funciones de accesibilidad fundamentales (por ejemplo, gestión de enfoque, regiones de hito de navegación), la experiencia general del usuario es terriblemente complicada para los usuarios con necesidades de accesibilidad en el punto en el que el nuevo editor es prácticamente imposible de usar.

La razón principal de esta falta de accesibilidad general se encuentra en el diseño general de Gutenberg, donde la accesibilidad no se ha incorporado en el proceso de diseño.

La retroalimentación de los usuarios de accesibilidad se ha evaluado constantemente y Gutenberg es en realidad una regresión en términos de nivel de accesibilidad, en comparación con el editor anterior “

Tras la renuncia de Rian, Automattic ha incorporado a  Matthew MacPherson al proyecto a tiempo completo y será quien se encargue de continuar mejorando la accesibilidad.

Mari Carmen de Albaya explicaba en un artículo de su blog, de primera mano, los problemas de usabilidad en Gutenberg con los que ella se había encontrado.

Herramienta recomendada

Esta semana te recomiendo una herramienta online Revealit.me, un sistema que nos permite enviar mensajes secretos a otra persona.

Una vez que ingresas en la web, se te habilita una caja en la que debes escribir el texto que quieres enviar. Tras lo cual, se te facilita una URL de un único uso. La puedes copiar y pegar en algún correo o enviarlo directamente desde la aplicación.

Una vez que el enlace es abierto, el mensaje no se puede volver a visualizar más.

 

Y hasta aquí el episodio de hoy. Nos escuchamos dentro de 7 días en un nuevo episodio de WPnovatos!

Juanma Aranda

Ayudo a usuarios noveles a dar sus primeros pasos con WordPress mediante mentorías individuales.
También creo vídeotutoriales en español para desarrolladores de WordPress que quieren mejorar su servicio de ayuda a clientes.

Ver todos los artículos

5 comentarios

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Información básica sobre protección de datos

El responsable del proceso es Juanma Aranda | Tus datos serán tratados para gestionar y moderar tus comentarios | La legitimación del tratamiento es por consentimiento del interesado | No se transferirá ningún dato a terceros, salvo obligación legal | Tienes derecho a acceder, rectificar y suprimir los datos, así como otros derechos, como se explica en la política de privacidad.

 

Cupón Descuento

15% Descuento
Ver el cupón
cupon descuento full text search

Fulltextsearch -15%

Complementa el buscador de WordPress agregando relevancia a los resultados.
Ir a la promoción
neque. ut Donec porta. ut tristique nec tempus